Publisert av: pertm | 16.01.10

Ny ukenr oppsett

I starten av 2010 så ble måten man teller ukenummer forandret slik at 1.1 ikke lenger nødvendigvis er uke 1. Det skjer hvis det er 3 eller mindre dager i den første uka i det nye året. Vel denne formelen gjør at Excel sin formel ikke lenger gir riktig resultat.

Formelen for å bestemme uke nr er

=UKENR(A1;2)

Når A1 er en dato.

For 2010 og noen andre år vil denne gi feil resultat, de første dagene skal fortsette fra den siste uka fra forrige år.

=HVIS(OG(ÅR(A1)>2009;2=UKENR(DATO(ÅR(A1);1;4);2));HVIS(UKENR(A1;2)=1;

UKENR(DATO(ÅR(A1)-1;12;31);2);UKENR(A1;2)-1);UKENR(A1;2))

Her er min løsning på problemet. Alle eldre år vil ha den gamle tellemetoden, mens nye vil ha riktig. Denne formelen tar og ser om uke 2 har startet på den gamle metoden, hvis det har skjedd så trekkes en fra alle uke nummer utenom for de opptil 3 første dagene som får ukenummer fra siste dag i det forrige året. Det kan godt være at det finnes enklere metoder for å gjøre dette og jeg vil tro at etterhvert vil vel formelen bli fikset. Jeg ser at Calc har ikke dette problemet med sin formel.

For å bruke formelen UKENR så må man inn i Alternativer og legge til Analyseverktøy under Tillegg.

 

Edit 18.10 2014

Fikset slik at hele formelen vises.

Jeg er usikker på om dette gjelder på siste versjoner på excel siden jeg ikke har kontrollert det


Legg igjen en kommentar

Fyll inn i feltene under, eller klikk på et ikon for å logge inn:

WordPress.com-logo

Du kommenterer med bruk av din WordPress.com konto. Logg ut / Endre )

Twitter picture

Du kommenterer med bruk av din Twitter konto. Logg ut / Endre )

Facebookbilde

Du kommenterer med bruk av din Facebook konto. Logg ut / Endre )

Google+ photo

Du kommenterer med bruk av din Google+ konto. Logg ut / Endre )

Kobler til %s

Kategorier

%d bloggers like this: