Publisert av: pertm | 12.08.09

Array formler – kraftigere formler

For en stund siden ble jeg oppmerksom på array formler. Det er en typer formler som gjør at  man kan kutte ut mange celler med omregning for å få til ting en ønsker å gjøre med Excel.

Hvis en skal finne en sum, antall, største, minste eller noe slikt med en eller flere betingelser så er array formler nyttige. Skal en finne ut summen av tall avhengig av datoen og vi vil hade som er i august 2009

{=SUMMER(HVIS(ÅR(A1:A20)=2009;HVIS(MÅNED(A1:A20)=8;B1:B20)))}

Dette er slik formelen blir senede ut, men de ekstra parantesene {} skal ikke skrives i cella og for å aktivere den holder det ikke å trykke enter, man må trykke CTRL + SHIFT + ENTER for å få en array formel til å virke.

Formler over flere celler

Det er også mulig å bruke array formler over  flere celler. Hvis en markerer 6 celler i samme rad og skriver inn dette

={1;2;3;4;5;6}

Her skal {} taes med, man må fortsatt bruke CTRL + SHIFT + ENTER. Hva er fordelen med dette, ikke så mye selv om for å forandre/slette formelen må man fjerne alle cellene som den står i, slik at det er vanskeligere for noen å fjerne den med et uhell.

Skal man gjøre det samme i en kolonne så må man gjøre slik

={1\2\3\4\5\6}

Har man Engelsk versjon er det litt mer opplagt hva man bruker for da blir det «,» og «;» mens vi som her i Norge må bruke «;» og «\».

Man kan selvsagt også ha 2 dimensjonale array, slik som denne som går over 6×6 celler og sumerer tallene 1 – 6 i rader og koloner.

=B1:G1+A2:A7

Liten advarsel

Det er ikke alle formler som funkerer med array formler, noen vil ikke alltid gi det reslutatet en forventer seg, så en bør kontrollere at resultatet stemmer, spesielt i starten.

Store array formler kan være tunge og ta mye CPU slik at det kan bli tregt.


Legg igjen en kommentar

Fyll inn i feltene under, eller klikk på et ikon for å logge inn:

WordPress.com-logo

Du kommenterer med bruk av din WordPress.com konto. Logg ut / Endre )

Twitter picture

Du kommenterer med bruk av din Twitter konto. Logg ut / Endre )

Facebookbilde

Du kommenterer med bruk av din Facebook konto. Logg ut / Endre )

Google+ photo

Du kommenterer med bruk av din Google+ konto. Logg ut / Endre )

Kobler til %s

Kategorier

%d bloggers like this: